• IAIN Palangka Raya
  • TIPD
  • IAIN Palangka Raya

Kamis, 22 Oktober 2020

Implementasi Prioritas Bandwidth Video Conference Zoom di Mikrotik

Address Lists

Untuk langkah pertama, tambahkan List IP server Zoom pada Firewall>Address-Lists router. Agar lebih mudah, silahkan cek list ip server zoom disini : zoom-ip
Copy script zoom-ip tersebut dan masukkan kedalam router dengan membuka New Terminal lalu klik-kanan Paste.

Jika sudah berhasil, cek ulang pada menu IP>Firewall>Address Lists apakah IP Zoom sudah tertambahkan secara otomatis. Akan ada list IP server Zoom dengan nama "zoom_ip".

Hasil menambahkan address list zoom


Gak semua IP yang digunakan oleh server Zoom ada pada script tersebut. Untuk menambahkan secara otomatis, tambahkan rule mangle berdasarkan port yang digunakan oleh aplikasi zoom.

Tambahkan dua rule untuk TCP dan UDP dengan destination port yaitu port 3478, 3479, 5090, 5091, 8801-8810 (selain 80 dan 443).

Berikut command yang digunakan :

/ip firewall mangle

add chain=prerouting dst-address-list=!zoom_ip dst-port=3478,3479,5090,5091,8801-8810 protocol=tcp action=add-dst-to-address-list address-list=zoom_ip;

add chain=prerouting dst-address-list=!zoom_ip dst-port=3478,3479,5090,5091,8801-8810 protocol=udp action=add-dst-to-address-list address-list=zoom_ip;


Setelah itu, untuk nangkap traffic koneksi app Zoom, tambah rule baru di mangle dengan action mark-connection. Port diisi port yang digunakan oleh app zoom yaitu Protocol TCP dan UDP 3478, 3479, 5090, 5091, 8801-8810. lalu kasih nama, disini aku kasih nama "koneksi_zoom".

Berikut command yang digunakan :


/ip firewall mangle

add chain=prerouting protocol=tcp dst-port=3478,3479,5090,5091,8801-8810 action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes;

add chain=prerouting protocol=udp dst-port=3478,3479,5090,5091,8801-8810 action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes;


Selain port 3478, 3479, 5090, 5091, 8801-8810, aplikasi Zoom juga menggunakan protokol TCP 80 dan TCP 443. Tambahkan rule baru dengan dst-port=80,443 dan Dst. Address List = zoom_ip yang sudah ditambahkan tadi.

Berikut command yang digunakan :

/ip firewall mangle add chain=prerouting protocol=tcp dst-port=80,443 dst-address-list=zoom_ip action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes


Setelah koneksi tertangkap, ada satu rule lagi yang harus ditambahkan yaitu mark-packet. Tambahkan rule baru dengan Action Mark Packet beri nama baru, misal packet_zoom. Pastikan connection mark diisi mark-connection = koneksi_zoom yang sudah dibuat tadi.Packet-mark ini yang akan kita gunakan untuk bandwidth management, baik pada menu simple queue atau pada queue tree.

Berikut command yang digunakan :

/ip firewall mangle
add chain=forward action=mark-packet connection-mark=koneksi_zoom new-packet-mark=paket_zoom passthrough=no


maka hasilnya akan seperti gambar dibawah yang ada blok biru nya

Hasil Mangle Zoom App

Sampai di langkah ini untuk ngetes berhasil atau tidaknya coba kalian buka app zoom nya terserah di hp atau di Pc, jika value pada kolom Bytes dan Packet ada pertambahan berarti berhasil.

Hasil Queue tree


Sumber : https://mikrotik.id/artikel_lihat.php?id=394

Kontak Kami

Masukan dan Kritikan Anda sangat berharga bagi Kami


Silakan menghubungi kami melalui kontak kami,
atau Anda dapat mengirim pesan melalui kontak pesan di bawah ini.
Saran dan masukan Anda sangat berharga bagi kami untuk peningkatan layanan kami.
salam hangat
UPT TIPD.


Mohon berkomentar dengan santun. Terima kasih.

Alamat

Gedung Laboratorium Terpadu Lt. 2 Kampus IAIN Palangka Raya
Jl. G. Obos Kompleks Islamic Centre Palangka Raya KP 73112

Telepon / SMS / Whatsapp

+(62) 858 2108 3000

Peta